Excel – Doppelte Einträge farbig markieren

[tag]Excel
Möglichkeit 1:
Beispiel: Namen A1:A500

A1 anklicken – Format – bedingte Formatierung –
Bedingung 1: Formel ist – =ZÄHLENWENN($A$1;$A$500;A1)>1
Format – hier Muster und Farbe wählen.
ok.

Jetzt den Format-übertragen-Pinsel in der Symbolleiste doppelklicken und in die übrigen Zellen aus A1 das Format übertragen.

Möglichkeit 2:

Code:
Option Explicit

Public Sub Doppelte_Rot()
Dim lngZeile As Long
Dim lngZeilenSprung As Long
Dim strSuchwert As String

lngZeile = Cells(Rows.Count, 1).End(xlUp).Row

For lngZeilenSprung = lngZeile To 1 Step -1
strSuchwert = Cells(lngZeilenSprung, 1).Value
If Application.WorksheetFunction.CountIf(Range(Cells(1, 1), Cells(lngZeile, 1)), strSuchwert) <> 1 Then
Cells(lngZeilenSprung, 1).Interior.ColorIndex = 3
End If
Next lngZeilenSprung

End Sub

Werbeanzeigen