Excel – Doppelte Einträge farbig markieren

[tag]Excel
Möglichkeit 1:
Beispiel: Namen A1:A500

A1 anklicken – Format – bedingte Formatierung –
Bedingung 1: Formel ist – =ZÄHLENWENN($A$1;$A$500;A1)>1
Format – hier Muster und Farbe wählen.
ok.

Jetzt den Format-übertragen-Pinsel in der Symbolleiste doppelklicken und in die übrigen Zellen aus A1 das Format übertragen.

Möglichkeit 2:

Code:
Option Explicit

Public Sub Doppelte_Rot()
Dim lngZeile As Long
Dim lngZeilenSprung As Long
Dim strSuchwert As String

lngZeile = Cells(Rows.Count, 1).End(xlUp).Row

For lngZeilenSprung = lngZeile To 1 Step -1
strSuchwert = Cells(lngZeilenSprung, 1).Value
If Application.WorksheetFunction.CountIf(Range(Cells(1, 1), Cells(lngZeile, 1)), strSuchwert) <> 1 Then
Cells(lngZeilenSprung, 1).Interior.ColorIndex = 3
End If
Next lngZeilenSprung

End Sub

Werbeanzeigen

Fenster per VBA fixieren

So legen Sie Fenstereinstellungen per Makro fest

Das Fixieren von Fenstern ist besonders praktisch, weil Sie damit dafür sorgen können, dass Überschriften immer im Blick bleiben und beim Rollen der Excel-Tabelle nicht aus dem Blickfeld verschwinden.

Bei der interaktiven Arbeit können Sie ein Fenster über das Kommando "Fenster fixieren" aus dem Fenster-Menü einrasten. Klicken Sie dazu zuvor die Zelle an, an der die Fixierung beginnen soll. Wenn Sie das über ein Makro erledigen möchten, setzen Sie den folgenden Programmcode ein:

Sub FixiereFenster()
Range("B2").Select
ActiveWindow.FreezePanes = True
End Sub

An welcher Zelle Excel das Fenster fixiert, steuern Sie über die Festlegung der Zelladresse im Range-Kommando. Die folgende Abbildung zeigt ein Excel-Fenster mit fixierter Fenstereinstellung nach dem Starte des Makros


Ihr Portal zur Verschluesselung mit GnuPG: http://portable.gnupt.de

Excel Zellen zusammenfügen

Sub JoinCells()

Dim rCells As Range
Dim rRange As Range
Dim rStart As Range
Dim strStart As String
Dim iReply As Integer
On Error Resume Next

‚Allow user to nominate cells to join

Set rCells = Application.InputBox _
(Prompt:=“Select the cells to join,“ _
& „use Ctrl for non-contiguous cells.“, _
Title:=“CONCATENATION OF CELLS“, Type:=8)

If rCells Is Nothing Then ‚Cancelled or mistake
iReply = MsgBox(„Invalid selection!“, _
vbQuestion + vbRetryCancel)

If iReply = vbCancel Then
On Error GoTo 0
Exit Sub
Else
Run „JoinCells“ ‚Try again
End If
End If

‚Set range variable to first cell

Set rStart = rCells(1, 1)

‚Loop through cells chosen

For Each rRange In rCells

strStart = rRange ‚parse cell content to a String
rRange.Clear ‚Clear contents of cell
‚Replace the original contents of first cell with „“, then _
join the text
rStart = Trim(Replace(rStart, rStart, „“) & “ “ _
& rStart & “ “ & strStart)
Next rRange

On Error GoTo 0

End Sub